Vulnerability · Published Mar 3, 2025 · Assigned by mitre

CVE-2025-27371

Medium 6.9

In plain English

A medium-severity security flaw in RFC 7523 from IETF. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities).

Severity (CVSS 3.1)6.9Medium
Exploit odds (30 days)0.3%top 71.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

In certain IETF OAuth 2.0-related specifications, when the JSON Web Token Profile for OAuth 2.0 Client Authentication mechanism is used, there are ambiguities in the audience values of JWTs sent to authorization servers. The affected RFCs may include RFC 7523, and also RFC 7521, RFC 7522, RFC 9101 (JAR), and RFC 9126 (PAR).

Affected products (as reported)

VendorProductVersions
IETF RFC 7523 7523

Weakness: CWE-305 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N

References