Vulnerability · Published Jul 17, 2024 · Assigned by apache

CVE-2024-39877Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler

High 8.8

In plain English

A high-severity code injection in Apache Airflow from Apache Software Foundation. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.7% (higher than 78% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)1.7%top 22.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-airflow2.9.3GHSA-g5hv-r743-v8pm
PyPIapache-airflow2.9.3PYSEC-2024-190

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Airflow 2.4.0 – before 2.9.3

Weakness: CWE-94, CWE-277 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References