Vulnerability · Published Feb 28, 2024 · Assigned by apache

CVE-2024-24779Apache Superset: Improper data authorization when creating a new dataset

Medium 5.0

In plain English

A medium-severity incorrect authorization in Apache Superset from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.0Medium
Exploit odds (30 days)0.7%top 45.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Apache Superset with custom roles that include `can write on dataset` and without all data access permissions, allows for users to create virtual datasets to data they don't have access to. These users could then use those virtual datasets to get access to unauthorized data. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-superset3.0.4GHSA-wr6g-9wcr-cmqj
PyPIapache-superset3.1.1GHSA-wr6g-9wcr-cmqj
PyPIapache-superset3.0.4, 3.1.1PYSEC-2026-1191

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Superset 0 – before 3.0.43.1.0 – before 3.1.1

Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N

References