Vulnerability · Published Feb 9, 2024 · Assigned by apache
CVE-2023-50291Apache Solr: System Property redaction logic inconsistency can lead to leaked passwords
High 7.5
In plain English
A high-severity security flaw in Apache Solr from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.3% (higher than 88% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Insufficiently Protected Credentials vulnerability in Apache Solr. This issue affects Apache Solr: from 6.0.0 through 8.11.2, from 9.0.0 before 9.3.0. One of the two endpoints that publishes the Solr process' Java system properties, /admin/info/properties, was only setup to hide system properties that had "password" contained in the name. There are a number of sensitive system properties, such as "basicauth" and "aws.secretKey" do not contain "password", thus their values were published via the "/admin/info/properties" endpoint. This endpoint populates the list of System Properties on the home screen of the Solr Admin page, making the exposed credentials visible in the UI. This /admin/info/properties endpoint is protected under the "config-read" permission. Therefore, Solr Clouds with Authorization enabled will only be vulnerable through logged-in users that have the "config-read" permission. Users are recommended to upgrade to version 9.3.0 or 8.11.3, which fixes the issue. A single option now controls hiding Java system property for all endpoints, "-Dsolr.hiddenSysProps". By default all known sensitive properties are hidden (including "-Dbasicauth"), as well as any property with a name containing "secret" or "password". Users who cannot upgrade can also use the following Java system property to fix the issue: '-Dsolr.redaction.system.pattern=.*(password|secret|basicauth).*'
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | lucene-solr | 3.6.2+dfsg-23 | DEBIAN-CVE-2023-50291 |
| Debian:13 | lucene-solr | 3.6.2+dfsg-23 | DEBIAN-CVE-2023-50291 |
| Debian:14 | lucene-solr | 3.6.2+dfsg-23 | DEBIAN-CVE-2023-50291 |
| Maven | org.apache.solr:solr-core | 8.11.3 | GHSA-3hwc-rqwp-v36q |
| Maven | org.apache.solr:solr-core | 9.3.0 | GHSA-3hwc-rqwp-v36q |
| Ubuntu:22.04:LTS | lucene-solr | no fix listed | UBUNTU-CVE-2023-50291 |
| Ubuntu:24.04:LTS | lucene-solr | no fix listed | UBUNTU-CVE-2023-50291 |
| Ubuntu:25.10 | lucene-solr | no fix listed | UBUNTU-CVE-2023-50291 |
| Ubuntu:26.04:LTS | lucene-solr | no fix listed | UBUNTU-CVE-2023-50291 |
| Ubuntu:26.10 | lucene-solr | no fix listed | UBUNTU-CVE-2023-50291 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Solr | 6.0.0 – through 8.11.29.0.0 – before 9.3.0 |
Weakness: CWE-522 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N