Vulnerability · Published Jan 10, 2024 · Assigned by GitHub_M
CVE-2023-49295quic-go's path validation mechanism can cause denial of service
Medium 6.4
In plain English
A medium-severity uncontrolled resource consumption in quic-go from quic-go. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with a PATH_RESPONSE frame. The attacker can prevent the receiver from sending out (the vast majority of) these PATH_RESPONSE frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. This vulnerability has been patched in versions 0.37.7, 0.38.2 and 0.39.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | golang-github-lucas-clemente-quic-go | no fix listed | DEBIAN-CVE-2023-49295 |
| Debian:13 | golang-github-lucas-clemente-quic-go | 0.38.2-1 | DEBIAN-CVE-2023-49295 |
| Debian:14 | golang-github-lucas-clemente-quic-go | 0.38.2-1 | DEBIAN-CVE-2023-49295 |
| Go | github.com/quic-go/quic-go | 0.38.2 | GHSA-ppxx-5m9h-6vxf |
| Go | github.com/quic-go/quic-go | 0.37.7, 0.38.2, 0.39.4, 0.40.1 | GO-2024-2459 |
| Go | github.com/quic-go/quic-go | 0.37.7 | GHSA-ppxx-5m9h-6vxf |
| Go | github.com/quic-go/quic-go | 0.40.1 | GHSA-ppxx-5m9h-6vxf |
| Go | github.com/quic-go/quic-go | 0.39.4 | GHSA-ppxx-5m9h-6vxf |
| Ubuntu:22.04:LTS | golang-github-lucas-clemente-quic-go | no fix listed | UBUNTU-CVE-2023-49295 |
| Ubuntu:24.04:LTS | golang-github-lucas-clemente-quic-go | no fix listed | UBUNTU-CVE-2023-49295 |
| Ubuntu:25.10 | golang-github-lucas-clemente-quic-go | no fix listed | UBUNTU-CVE-2023-49295 |
| Ubuntu:26.04:LTS | golang-github-lucas-clemente-quic-go | no fix listed | UBUNTU-CVE-2023-49295 |
| Ubuntu:26.10 | golang-github-lucas-clemente-quic-go | no fix listed | UBUNTU-CVE-2023-49295 |
Affected products (as reported)
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:H
References
- https://github.com/quic-go/quic-go/security/advisories/GHSA-ppxx-5m9h-6vxf x_refsource_CONFIRM
- https://github.com/quic-go/quic-go/commit/17fc98c2d81dbe685c19702dc694a9d606ac56dc x_refsource_MISC
- https://github.com/quic-go/quic-go/commit/21609ddfeff93668c7625a85eb09f1541fdad965 x_refsource_MISC
- https://github.com/quic-go/quic-go/commit/3a9c18bcd27a01c551ac9bf8bd2b4bded77c189a x_refsource_MISC
- https://github.com/quic-go/quic-go/commit/554d543b50b917369fb1394cc5396d928166cf49 x_refsource_MISC
- https://github.com/quic-go/quic-go/commit/6cc3d58935426191296171a6c0d1ee965e10534e x_refsource_MISC
- https://github.com/quic-go/quic-go/commit/9aaefe19fc3dc8c8917cc87e6128bb56d9e9e6cc x_refsource_MISC
- https://github.com/quic-go/quic-go/commit/a0ffa757499913f7be69aa78f573a6aee3430ae4 x_refsource_MISC
- https://github.com/quic-go/quic-go/commit/d7aa627ebde91cf799ada2a07443faa9b1e5abb8 x_refsource_MISC
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/G5RSHDTVMYAIGYVVFGKTMFHAZJMA3EVV/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZE7IOKXX5AATU2WR3V76X5Y3A44QAATG/