Vulnerability · Published Dec 4, 2023 · Assigned by GitHub_M
CVE-2023-49285Denial of Service in HTTP Message Processing in Squid
High 8.6
In plain English
A high-severity security flaw in squid from squid-cache. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 88.1% (higher than 99.8% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Due to a Buffer Overread bug Squid is vulnerable to a Denial of Service attack against Squid HTTP Message processing. This bug is fixed by Squid version 6.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | libecap | 1.0.1-2.module_el8.6.0+3048+383bc947 | ALSA-2024:0046 |
| AlmaLinux:8 | libecap | 1.0.1-2.module_el8.6.0+2741+01592ae8 | ALSA-2024:0046 |
| AlmaLinux:8 | libecap-devel | 1.0.1-2.module_el8.6.0+3048+383bc947 | ALSA-2024:0046 |
| AlmaLinux:8 | libecap-devel | 1.0.1-2.module_el8.6.0+2741+01592ae8 | ALSA-2024:0046 |
| AlmaLinux:8 | squid | 7:4.15-7.module_el8.9.0+3708+6acaac63.5 | ALSA-2024:0046 |
| AlmaLinux:9 | squid | 7:5.5-6.el9_3.5 | ALSA-2024:0071 |
| Alpine:v3.20 | squid | 6.5-r0 | ALPINE-CVE-2023-49285 |
| Alpine:v3.21 | squid | 6.5-r0 | ALPINE-CVE-2023-49285 |
| Alpine:v3.22 | squid | 6.5-r0 | ALPINE-CVE-2023-49285 |
| Alpine:v3.23 | squid | 6.5-r0 | ALPINE-CVE-2023-49285 |
| Alpine:v3.24 | squid | 6.5-r0 | ALPINE-CVE-2023-49285 |
| Debian:12 | squid | 5.7-2+deb12u1 | DSA-5637-1 |
| Debian:12 | squid | 5.7-2+deb12u1 | DEBIAN-CVE-2023-49285 |
| Debian:13 | squid | 6.5-1 | DEBIAN-CVE-2023-49285 |
| Debian:14 | squid | 6.5-1 | DEBIAN-CVE-2023-49285 |
| Rocky Linux:8 | libecap | 0:1.0.1-2.module+el8.9.0+1437+df5ea8f0 | RLSA-2024:0046 |
| Rocky Linux:8 | squid | 7:4.15-7.module+el8.9.0+1568+6d4fd5d4.1 | RLSA-2024:0046 |
| Ubuntu:22.04:LTS | squid | 5.7-0ubuntu0.22.04.3 | USN-6594-1 |
| Ubuntu:22.04:LTS | squid | 5.7-0ubuntu0.22.04.3 | UBUNTU-CVE-2023-49285 |
| Ubuntu:24.04:LTS | squid | 6.5-1ubuntu1 | UBUNTU-CVE-2023-49285 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| squid-cache | squid | >= 2.2, < 6.5 |
Weakness: CWE-126 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
References
- https://github.com/squid-cache/squid/security/advisories/GHSA-8w9r-p88v-mmx9 x_refsource_CONFIRM
- https://github.com/squid-cache/squid/commit/77b3fb4df0f126784d5fd4967c28ed40eb8d521b x_refsource_MISC
- https://github.com/squid-cache/squid/commit/deee944f9a12c9fd399ce52f3e2526bb573a9470 x_refsource_MISC
- http://www.squid-cache.org/Versions/v5/SQUID-2023_7.patch x_refsource_MISC
- http://www.squid-cache.org/Versions/v6/SQUID-2023_7.patch x_refsource_MISC
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MEV66D3PAAY6K7TWDT3WZBLCPLASFJDC/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/A5QASTMCUSUEW3UOMKHZJB3FTONWSRXS/
- https://lists.debian.org/debian-lts-announce/2024/01/msg00003.html
- https://security.netapp.com/advisory/ntap-20240119-0004/