Vulnerability · Published Nov 1, 2023 · Assigned by GitHub_M
CVE-2023-46724SQUID-2023:4 Denial of Service in SSL Certificate validation
High 8.6
In plain English
A high-severity out-of-bounds read in squid from squid-cache. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.8% (higher than 87% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Squid is a caching proxy for the Web. Due to an Improper Validation of Specified Index bug, Squid versions 3.3.0.1 through 5.9 and 6.0 prior to 6.4 compiled using `--with-openssl` are vulnerable to a Denial of Service attack against SSL Certificate validation. This problem allows a remote server to perform Denial of Service against Squid Proxy by initiating a TLS Handshake with a specially crafted SSL Certificate in a server certificate chain. This attack is limited to HTTPS and SSL-Bump. This bug is fixed in Squid version 6.4. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. Those who you use a prepackaged version of Squid should refer to the package vendor for availability information on updated packages.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | libecap | 1.0.1-2.module_el8.6.0+3048+383bc947 | ALSA-2024:0046 |
| AlmaLinux:8 | libecap | 1.0.1-2.module_el8.6.0+2741+01592ae8 | ALSA-2024:0046 |
| AlmaLinux:8 | libecap-devel | 1.0.1-2.module_el8.6.0+3048+383bc947 | ALSA-2024:0046 |
| AlmaLinux:8 | libecap-devel | 1.0.1-2.module_el8.6.0+2741+01592ae8 | ALSA-2024:0046 |
| AlmaLinux:8 | squid | 7:4.15-7.module_el8.9.0+3708+6acaac63.5 | ALSA-2024:0046 |
| AlmaLinux:9 | squid | 7:5.5-6.el9_3.5 | ALSA-2024:0071 |
| Alpine:v3.20 | squid | 6.4-r0 | ALPINE-CVE-2023-46724 |
| Alpine:v3.21 | squid | 6.4-r0 | ALPINE-CVE-2023-46724 |
| Alpine:v3.22 | squid | 6.4-r0 | ALPINE-CVE-2023-46724 |
| Alpine:v3.23 | squid | 6.4-r0 | ALPINE-CVE-2023-46724 |
| Alpine:v3.24 | squid | 6.4-r0 | ALPINE-CVE-2023-46724 |
| Debian:12 | squid | 5.7-2+deb12u1 | DSA-5637-1 |
| Debian:12 | squid | 5.7-2+deb12u1 | DEBIAN-CVE-2023-46724 |
| Debian:13 | squid | 6.5-1 | DEBIAN-CVE-2023-46724 |
| Debian:14 | squid | 6.5-1 | DEBIAN-CVE-2023-46724 |
| Rocky Linux:8 | libecap | 0:1.0.1-2.module+el8.9.0+1437+df5ea8f0 | RLSA-2024:0046 |
| Rocky Linux:8 | squid | 7:4.15-7.module+el8.9.0+1568+6d4fd5d4.1 | RLSA-2024:0046 |
| Ubuntu:22.04:LTS | squid | 5.7-0ubuntu0.22.04.2 | USN-6500-1 |
| Ubuntu:22.04:LTS | squid | 5.7-0ubuntu0.22.04.2 | UBUNTU-CVE-2023-46724 |
| Ubuntu:24.04:LTS | squid | 6.1-2ubuntu2 | UBUNTU-CVE-2023-46724 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| squid-cache | squid | >= 3.3.0.1, < 6.4 |
Weakness: CWE-125, CWE-129, CWE-786, CWE-823, CWE-1285 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
References
- https://github.com/squid-cache/squid/security/advisories/GHSA-73m6-jm96-c6r3 x_refsource_CONFIRM
- https://github.com/squid-cache/squid/commit/b70f864940225dfe69f9f653f948e787f99c3810 x_refsource_MISC
- http://www.squid-cache.org/Versions/v5/SQUID-2023_4.patch x_refsource_MISC
- http://www.squid-cache.org/Versions/v6/SQUID-2023_4.patch x_refsource_MISC
- https://security.netapp.com/advisory/ntap-20231208-0001/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MEV66D3PAAY6K7TWDT3WZBLCPLASFJDC/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/A5QASTMCUSUEW3UOMKHZJB3FTONWSRXS/