Vulnerability · Published Oct 9, 2023 · Assigned by GitHub_M
CVE-2023-43641libcue vulnerable to out-of-bounds array access
High 8.8
In plain English
A high-severity out-of-bounds write in libcue from lipnitsk. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 17.2% (higher than 97% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
libcue provides an API for parsing and extracting data from CUE sheets. Versions 2.2.1 and prior are vulnerable to out-of-bounds array access. A user of the GNOME desktop environment can be exploited by downloading a cue sheet from a malicious webpage. Because the file is saved to `~/Downloads`, it is then automatically scanned by tracker-miners. And because it has a .cue filename extension, tracker-miners use libcue to parse the file. The file exploits the vulnerability in libcue to gain code execution. This issue is patched in version 2.3.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | libcue | 2.2.1-r2 | ALPINE-CVE-2023-43641 |
| Alpine:v3.21 | libcue | 2.2.1-r2 | ALPINE-CVE-2023-43641 |
| Alpine:v3.22 | libcue | 2.2.1-r2 | ALPINE-CVE-2023-43641 |
| Alpine:v3.23 | libcue | 2.2.1-r2 | ALPINE-CVE-2023-43641 |
| Alpine:v3.24 | libcue | 2.2.1-r2 | ALPINE-CVE-2023-43641 |
| Debian:12 | libcue | 2.2.1-4+deb12u1 | DSA-5524-1 |
| Debian:12 | libcue | 2.2.1-4+deb12u1 | DEBIAN-CVE-2023-43641 |
| Debian:13 | libcue | 2.2.1-4.1 | DEBIAN-CVE-2023-43641 |
| Debian:14 | libcue | 2.2.1-4.1 | DEBIAN-CVE-2023-43641 |
| Ubuntu:22.04:LTS | libcue | 2.2.1-3ubuntu0.1 | USN-6423-1 |
| Ubuntu:22.04:LTS | libcue | 2.2.1-3ubuntu0.1 | UBUNTU-CVE-2023-43641 |
| Ubuntu:24.04:LTS | libcue | 2.2.1-4ubuntu1 | UBUNTU-CVE-2023-43641 |
Affected products (as reported)
Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://github.blog/2023-10-09-coordinated-disclosure-1-click-rce-on-gnome-cve-2023-43641/ x_refsource_CONFIRM
- https://github.com/lipnitsk/libcue/security/advisories/GHSA-5982-x7hv-r9cj x_refsource_MISC
- https://github.com/lipnitsk/libcue/commit/cfb98a060fd79dbc3463d85f0f29c3c335dfa0ea x_refsource_MISC
- https://github.com/lipnitsk/libcue/commit/fdf72c8bded8d24cfa0608b8e97f2eed210a920e x_refsource_MISC
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/57JEYTRFG4PVGZZ7HIEFTX5I7OONFFMI/
- https://lists.debian.org/debian-lts-announce/2023/10/msg00018.html
- https://www.debian.org/security/2023/dsa-5524
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PGQOMFDBXGM3DOICCXKCUS76OTKTSPMN/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XUS4HTNGGGUIFLYSKTODCRIOXLX5HGV3/
- http://packetstormsecurity.com/files/176128/libcue-2.2.1-Out-Of-Bounds-Access.html