Vulnerability · Published Sep 11, 2023 · Assigned by GitHub_M
CVE-2023-40032Potential segfault due to NULL pointer dereference in libvips
Medium 5.5
In plain English
A medium-severity null pointer dereference in libvips from libvips. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | vips | 8.14.1-3+deb12u1 | DEBIAN-CVE-2023-40032 |
| Debian:13 | vips | 8.14.4-1 | DEBIAN-CVE-2023-40032 |
| Debian:14 | vips | 8.14.4-1 | DEBIAN-CVE-2023-40032 |
Affected products (as reported)
Weakness: CWE-476 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/libvips/libvips/security/advisories/GHSA-33qp-9pq7-9584 x_refsource_CONFIRM
- https://github.com/libvips/libvips/pull/3604 x_refsource_MISC
- https://github.com/libvips/libvips/commit/e091d65835966ef56d53a4105a7362cafdb1582b x_refsource_MISC
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YU2FFC47X2XDEGEHEWAGLU5L3R6FEYD2/