Vulnerability · Published Jul 11, 2023 · Assigned by GitHub_M
CVE-2023-37280Pimcore admin UI vulnerable to Cross-site Scripting in two factor authentication setup page
Medium 5.0
In plain English
A medium-severity cross-site scripting in admin-ui-classic-bundle from pimcore. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Pimcore Admin Classic Bundle provides a Backend UI for Pimcore based on the ExtJS framework. An admin who has not setup two factor authentication before is vulnerable for this attack, without need for any form of privilege, causing the application to execute arbitrary scripts/HTML content. This vulnerability has been patched in version 1.0.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | pimcore/admin-ui-classic-bundle | 1.0.3 | GHSA-hqv9-6jqw-9g8m |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| pimcore | admin-ui-classic-bundle | < 1.0.3 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
References
- https://github.com/pimcore/admin-ui-classic-bundle/security/advisories/GHSA-hqv9-6jqw-9g8m x_refsource_CONFIRM
- https://github.com/pimcore/admin-ui-classic-bundle/pull/147 x_refsource_MISC
- https://github.com/pimcore/admin-ui-classic-bundle/commit/5fcd19bdc89a3fe4cb8ad8c356590e1e4740c743 x_refsource_MISC