Vulnerability · Published Oct 6, 2022 · Assigned by mitre

CVE-2022-41556

High 7.5

In plain English

A high-severity security flaw in the lighttpd package (Alpine). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.8% (higher than 90% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.5High
Exploit odds (30 days)3.8%top 9.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20lighttpd1.4.67-r0ALPINE-CVE-2022-41556
Alpine:v3.21lighttpd1.4.67-r0ALPINE-CVE-2022-41556
Alpine:v3.22lighttpd1.4.67-r0ALPINE-CVE-2022-41556
Alpine:v3.23lighttpd1.4.67-r0ALPINE-CVE-2022-41556
Alpine:v3.24lighttpd1.4.67-r0ALPINE-CVE-2022-41556
Debian:12lighttpd1.4.67-1DEBIAN-CVE-2022-41556
Debian:13lighttpd1.4.67-1DEBIAN-CVE-2022-41556
Debian:14lighttpd1.4.67-1DEBIAN-CVE-2022-41556
Ubuntu:22.04:LTSlighttpd1.4.63-1ubuntu3.1UBUNTU-CVE-2022-41556
Ubuntu:22.04:LTSlighttpd1.4.63-1ubuntu3.1USN-5903-1

Affected products (as reported)

VendorProductVersions
n/a n/a n/a

References