Vulnerability · Published Jul 14, 2022 · Assigned by hackerone
CVE-2022-32210
Medium 6.5
In plain English
A medium-severity improper certificate validation in https://github.com/nodejs/undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
`Undici.ProxyAgent` never verifies the remote server's certificate, and always exposes all request & response data to the proxy. This unexpectedly means that proxies can MitM all HTTPS traffic, and if the proxy's URL is HTTP then it also means that nominally HTTPS requests are actually sent via plain-text HTTP between Undici and the proxy server.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-undici | 5.6.1+dfsg1+~cs18.9.16-1 | DEBIAN-CVE-2022-32210 |
| Debian:13 | node-undici | 5.6.1+dfsg1+~cs18.9.16-1 | DEBIAN-CVE-2022-32210 |
| Debian:14 | node-undici | 5.6.1+dfsg1+~cs18.9.16-1 | DEBIAN-CVE-2022-32210 |
| npm | undici | 5.5.1 | GHSA-pgw7-wx7w-2w33 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| n/a | https://github.com/nodejs/undici | Fixed in version >= v5.5.1. Vulnerable between v4.8.2 and v5.5.0 |
Weakness: CWE-295
References
- https://hackerone.com/reports/1583680 x_refsource_MISC
- https://github.com/nodejs/undici/security/advisories/GHSA-pgw7-wx7w-2w33 x_refsource_MISC