Vulnerability · Published Jun 6, 2022 · Assigned by GitHub_M
CVE-2022-31030containerd CRI plugin: Host memory exhaustion through ExecSync
Medium 5.5
In plain English
A medium-severity uncontrolled resource consumption in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
containerd is an open source container runtime. A bug was found in the containerd's CRI implementation where programs inside a container can cause the containerd daemon to consume memory without bound during invocation of the `ExecSync` API. This can cause containerd to consume all available memory on the computer, denying service to other legitimate workloads. Kubernetes and crictl can both be configured to use containerd's CRI implementation; `ExecSync` may be used when running probes or when executing processes via an "exec" facility. This bug has been fixed in containerd 1.6.6 and 1.5.13. Users should update to these versions to resolve the issue. Users unable to upgrade should ensure that only trusted images and commands are used.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | containerd | 1.6.6-r0 | ALPINE-CVE-2022-31030 |
| Alpine:v3.21 | containerd | 1.6.6-r0 | ALPINE-CVE-2022-31030 |
| Alpine:v3.22 | containerd | 1.6.6-r0 | ALPINE-CVE-2022-31030 |
| Alpine:v3.23 | containerd | 1.6.6-r0 | ALPINE-CVE-2022-31030 |
| Alpine:v3.24 | containerd | 1.6.6-r0 | ALPINE-CVE-2022-31030 |
| Debian:12 | containerd | 1.6.6~ds1-1 | DEBIAN-CVE-2022-31030 |
| Debian:13 | containerd | 1.6.6~ds1-1 | DEBIAN-CVE-2022-31030 |
| Debian:14 | containerd | 1.6.6~ds1-1 | DEBIAN-CVE-2022-31030 |
| Go | github.com/containerd/containerd | 1.6.6 | GHSA-5ffw-gxpp-mxpf |
| Go | github.com/containerd/containerd | 1.5.13, 1.6.6 | GO-2022-0482 |
| Go | github.com/containerd/containerd | 1.5.13 | GHSA-5ffw-gxpp-mxpf |
| Ubuntu:22.04:LTS | containerd | 1.5.9-0ubuntu3.1 | UBUNTU-CVE-2022-31030 |
| Ubuntu:22.04:LTS | containerd | 1.5.9-0ubuntu3.1 | USN-5776-1 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| containerd | containerd | < 1.5.13>= 1.6.0, < 1.6.6 |
Weakness: CWE-400 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/containerd/containerd/security/advisories/GHSA-5ffw-gxpp-mxpf
- https://github.com/containerd/containerd/commit/c1bcabb4541930f643aa36a2b38655e131346382
- [oss-security] 20220606 CVE-2022-31030: containerd CRI plugin: Host memory exhaustion through ExecSync mailing-list
- DSA-5162 vendor-advisory
- FEDORA-2022-725ac93b48 vendor-advisory
- FEDORA-2022-1da581ac6d vendor-advisory
- GLSA-202401-31 vendor-advisory