Vulnerability · Published Mar 16, 2022 · Assigned by GitHub_M
CVE-2022-24728Cross-site Scripting in CKEditor4
Medium 5.4
In plain English
A medium-severity cross-site scripting in ckeditor4 from ckeditor. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4 prior to version 4.18.0. The vulnerability allows someone to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. This problem has been patched in version 4.18.0. There are currently no known workarounds.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | ckeditor | 4.19.0+dfsg-1 | DEBIAN-CVE-2022-24728 |
| Debian:12 | ckeditor3 | no fix listed | DEBIAN-CVE-2022-24728 |
| Packagist | drupal/core | 9.2.15, 9.3.8 | DRUPAL-CORE-2022-005 |
| Ubuntu:22.04:LTS | ckeditor3 | no fix listed | UBUNTU-CVE-2022-24728 |
| Ubuntu:24.04:LTS | ckeditor3 | no fix listed | UBUNTU-CVE-2022-24728 |
| Ubuntu:22.04:LTS | ldap-account-manager | no fix listed | UBUNTU-CVE-2022-24728 |
| Ubuntu:24.04:LTS | ldap-account-manager | no fix listed | UBUNTU-CVE-2022-24728 |
| Ubuntu:25.10 | ldap-account-manager | no fix listed | UBUNTU-CVE-2022-24728 |
| Ubuntu:26.04:LTS | ldap-account-manager | no fix listed | UBUNTU-CVE-2022-24728 |
| Ubuntu:22.04:LTS | request-tracker4 | no fix listed | UBUNTU-CVE-2022-24728 |
| Ubuntu:24.04:LTS | request-tracker4 | no fix listed | UBUNTU-CVE-2022-24728 |
| Ubuntu:25.10 | request-tracker4 | no fix listed | UBUNTU-CVE-2022-24728 |
| Ubuntu:26.04:LTS | request-tracker4 | no fix listed | UBUNTU-CVE-2022-24728 |
| npm | ckeditor4 | 4.18.0 | GHSA-4fc4-4p5g-6w89 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
References
- https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-4fc4-4p5g-6w89
- https://github.com/ckeditor/ckeditor4/commit/d158413449692d920a778503502dcb22881bc949
- https://ckeditor.com/cke4/release/CKEditor-4.18.0
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://www.drupal.org/sa-core-2022-005
- FEDORA-2022-b61dfd219b vendor-advisory
- FEDORA-2022-4c634ee466 vendor-advisory