Vulnerability · Published Mar 3, 2022 · Assigned by GitHub_M
CVE-2022-23648Insecure handling of image volumes in containerd CRI plugin
High 7.5
In plain English
A high-severity information exposure in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 27.4% (higher than 98% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
containerd is a container runtime available as a daemon for Linux and Windows. A bug was found in containerd prior to versions 1.6.1, 1.5.10, and 1.14.12 where containers launched through containerd’s CRI implementation on Linux with a specially-crafted image configuration could gain access to read-only copies of arbitrary files and directories on the host. This may bypass any policy-based enforcement on container setup (including a Kubernetes Pod Security Policy) and expose potentially sensitive information. Kubernetes and crictl can both be configured to use containerd’s CRI implementation. This bug has been fixed in containerd 1.6.1, 1.5.10, and 1.4.12. Users should update to these versions to resolve the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | containerd | 1.6.1-r0 | ALPINE-CVE-2022-23648 |
| Alpine:v3.21 | containerd | 1.6.1-r0 | ALPINE-CVE-2022-23648 |
| Alpine:v3.22 | containerd | 1.6.1-r0 | ALPINE-CVE-2022-23648 |
| Alpine:v3.23 | containerd | 1.6.1-r0 | ALPINE-CVE-2022-23648 |
| Alpine:v3.24 | containerd | 1.6.1-r0 | ALPINE-CVE-2022-23648 |
| Debian:12 | containerd | 1.6.1~ds1-1 | DEBIAN-CVE-2022-23648 |
| Debian:13 | containerd | 1.6.1~ds1-1 | DEBIAN-CVE-2022-23648 |
| Debian:14 | containerd | 1.6.1~ds1-1 | DEBIAN-CVE-2022-23648 |
| Go | github.com/containerd/containerd | 1.5.10 | GHSA-crp2-qrr5-8pq7 |
| Go | github.com/containerd/containerd | 1.4.13 | GHSA-crp2-qrr5-8pq7 |
| Go | github.com/containerd/containerd | 1.6.1 | GHSA-crp2-qrr5-8pq7 |
| Go | github.com/containerd/containerd | 1.4.13, 1.5.10, 1.6.1 | GO-2022-0344 |
| Ubuntu:22.04:LTS | containerd | 1.5.9-0ubuntu2 | UBUNTU-CVE-2022-23648 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| containerd | containerd | < 1.4.13>= 1.5.0, < 1.5.10>= 1.6.0, < 1.6.1 |
Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
References
- https://github.com/containerd/containerd/security/advisories/GHSA-crp2-qrr5-8pq7
- https://github.com/containerd/containerd/commit/10f428dac7cec44c864e1b830a4623af27a9fc70
- https://github.com/containerd/containerd/releases/tag/v1.4.13
- https://github.com/containerd/containerd/releases/tag/v1.5.10
- https://github.com/containerd/containerd/releases/tag/v1.6.1
- DSA-5091 vendor-advisory
- FEDORA-2022-dc35dd101f vendor-advisory
- FEDORA-2022-230f2b024b vendor-advisory
- http://packetstormsecurity.com/files/166421/containerd-Image-Volume-Insecure-Handling.html
- FEDORA-2022-d9c9bf56f6 vendor-advisory
- GLSA-202401-31 vendor-advisory