Vulnerability · Published Dec 14, 2022 · Assigned by GitHub_M
CVE-2022-23503TYPO3 vulnerable to Arbitrary Code Execution via Form Framework
High 7.5
In plain English
A high-severity code injection in typo3 from TYPO3. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
TYPO3 is an open source PHP based web content management system. Versions prior to 8.7.49, 9.5.38, 10.4.33, 11.5.20, and 12.1.1 are vulnerable to Code Injection. Due to the lack of separating user-submitted data from the internal configuration in the Form Designer backend module, it is possible to inject code instructions to be processed and executed via TypoScript as PHP code. The existence of individual TypoScript instructions for a particular form item and a valid backend user account with access to the form module are needed to exploit this vulnerability. This issue is patched in versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | typo3/cms | 10.4.33 | GHSA-c5wx-6c2c-f7rm |
| Packagist | typo3/cms | 11.5.20 | GHSA-c5wx-6c2c-f7rm |
| Packagist | typo3/cms | 12.1.1 | GHSA-c5wx-6c2c-f7rm |
| Packagist | typo3/cms-core | 11.5.20 | GHSA-c5wx-6c2c-f7rm |
| Packagist | typo3/cms-core | 8.7.49 | GHSA-c5wx-6c2c-f7rm |
| Packagist | typo3/cms-core | 12.1.1 | GHSA-c5wx-6c2c-f7rm |
| Packagist | typo3/cms-core | 9.5.38 | GHSA-c5wx-6c2c-f7rm |
| Packagist | typo3/cms-core | 10.4.33 | GHSA-c5wx-6c2c-f7rm |
Affected products (as reported)
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/TYPO3/typo3/security/advisories/GHSA-c5wx-6c2c-f7rm x_refsource_CONFIRM