Vulnerability · Published Jan 6, 2022 · Assigned by GitHub_M
CVE-2022-21662Stored XSS in WordPress
High 8.0
In plain English
A high-severity cross-site scripting in wordpress-develop from WordPress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 64.5% (higher than 99.2% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Low-privileged authenticated users (like author) in WordPress core are able to execute JavaScript/perform stored XSS attack, which can affect high-privileged users. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | wordpress | 5.8.3+dfsg1-1 | DEBIAN-CVE-2022-21662 |
| Debian:13 | wordpress | 5.8.3+dfsg1-1 | DEBIAN-CVE-2022-21662 |
| Debian:14 | wordpress | 5.8.3+dfsg1-1 | DEBIAN-CVE-2022-21662 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| WordPress | wordpress-develop | < 5.8.3 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
References
- https://wordpress.org/news/2022/01/wordpress-5-8-3-security-release/ x_refsource_MISC
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-699q-3hj9-889w x_refsource_CONFIRM
- DSA-5039 vendor-advisory, x_refsource_DEBIAN
- FEDORA-2022-8472dd59ff vendor-advisory, x_refsource_FEDORA
- FEDORA-2022-e37e1e6c7a vendor-advisory, x_refsource_FEDORA
- [debian-lts-announce] 20220123 [SECURITY] [DLA 2884-1] wordpress security update mailing-list, x_refsource_MLIST