Vulnerability · Published Feb 17, 2022 · Assigned by canonical
CVE-2021-44730snapd could be made to escalate privileges and run programs as administrator
High 7.8
In plain English
A high-severity security flaw in snapd from Canonical Ltd.. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
snapd 2.54.2 did not properly validate the location of the snap-confine binary. A local attacker who can hardlink this binary to another location to cause snap-confine to execute other arbitrary binaries and hence gain privilege escalation. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | snapd | 2.54.3-1 | DEBIAN-CVE-2021-44730 |
| Debian:13 | snapd | 2.54.3-1 | DEBIAN-CVE-2021-44730 |
| Debian:14 | snapd | 2.54.3-1 | DEBIAN-CVE-2021-44730 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Canonical Ltd. | snapd | unspecified – through 2.54.2 |
Weakness: CWE-59 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
References
- https://ubuntu.com/security/notices/USN-5292-1 x_refsource_MISC
- [oss-security] 20220218 CVE-2021-4120: Insufficient validation of snap content interface and layout paths mailing-list, x_refsource_MLIST
- FEDORA-2022-82bea71e5a vendor-advisory, x_refsource_FEDORA
- FEDORA-2022-5df8b52ba4 vendor-advisory, x_refsource_FEDORA
- DSA-5080 vendor-advisory, x_refsource_DEBIAN
- [oss-security] 20220223 Re: CVE-2021-44731: Race condition in snap-confine's setup_private_mount() mailing-list, x_refsource_MLIST