Vulnerability · Published Sep 7, 2021 · Assigned by GitHub_M
CVE-2021-32802Preview generation used third-party library not suited for user-generated content in Nextcloud server
Critical 9.3
In plain English
A critical-severity security flaw in security-advisories from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.6% (higher than 85% of all known vulnerabilities).
Official description
Nextcloud server is an open source, self hosted personal cloud. Nextcloud supports rendering image previews for user provided file content. For some image types, the Nextcloud server was invoking a third-party library that wasn't suited for untrusted user-supplied content. There are several security concerns with passing user-generated content to this library, such as Server-Side-Request-Forgery, file disclosure or potentially executing code on the system. The risk depends on your system configuration and the installed library version. It is recommended that the Nextcloud Server is upgraded to 20.0.12, 21.0.4 or 22.1.0. These versions do not use this library anymore. As a workaround users may disable previews by setting `enable_previews` to `false` in `config.php`.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | < 20.0.12>= 21.0.0, < 21.0.4>= 22.0.0, < 22.1.0 |
Weakness: CWE-829 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:L
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-m682-v4g9-wrq7 x_refsource_CONFIRM
- https://hackerone.com/reports/1261413 x_refsource_MISC
- https://docs.nextcloud.com/server/21/admin_manual/configuration_files/previews_configuration.html#disabling-previews x_refsource_MISC
- GLSA-202208-17 vendor-advisory, x_refsource_GENTOO