Vulnerability · Published Jun 24, 2021 · Assigned by GitHub_M
CVE-2021-32708Time-of-check Time-of-use (TOCTOU) Race Condition in league/flysystem
Critical 9.8
In plain English
A critical-severity security flaw in flysystem from thephpleague. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.5% (higher than 89% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Flysystem is an open source file storage library for PHP. The whitespace normalisation using in 1.x and 2.x removes any unicode whitespace. Under certain specific conditions this could potentially allow a malicious user to execute code remotely. The conditions are: A user is allowed to supply the path or filename of an uploaded file, the supplied path or filename is not checked against unicode chars, the supplied pathname checked against an extension deny-list, not an allow-list, the supplied path or filename contains a unicode whitespace char in the extension, the uploaded file is stored in a directory that allows PHP code to be executed. Given these conditions are met a user can upload and execute arbitrary code on the system under attack. The unicode whitespace removal has been replaced with a rejection (exception). For 1.x users, upgrade to 1.1.4. For 2.x users, upgrade to 2.1.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | php-league-flysystem | 1.1.3-4 | DEBIAN-CVE-2021-32708 |
| Debian:13 | php-league-flysystem | 1.1.3-4 | DEBIAN-CVE-2021-32708 |
| Debian:14 | php-league-flysystem | 1.1.3-4 | DEBIAN-CVE-2021-32708 |
| Packagist | league/flysystem | 1.1.4 | GHSA-9f46-5r25-5wfm |
| Packagist | league/flysystem | 2.1.1 | GHSA-9f46-5r25-5wfm |
| Ubuntu:22.04:LTS | php-league-flysystem | no fix listed | UBUNTU-CVE-2021-32708 |
| Ubuntu:24.04:LTS | php-league-flysystem | no fix listed | UBUNTU-CVE-2021-32708 |
| Ubuntu:25.10 | php-league-flysystem | no fix listed | UBUNTU-CVE-2021-32708 |
| Ubuntu:26.04:LTS | php-league-flysystem | no fix listed | UBUNTU-CVE-2021-32708 |
| Ubuntu:26.10 | php-league-flysystem | no fix listed | UBUNTU-CVE-2021-32708 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| thephpleague | flysystem | < 1.1.4>= 2.0.0, < 2.1.1 |
Weakness: CWE-367 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/thephpleague/flysystem/security/advisories/GHSA-9f46-5r25-5wfm x_refsource_CONFIRM
- https://github.com/thephpleague/flysystem/commit/a3c694de9f7e844b76f9d1b61296ebf6e8d89d74 x_refsource_MISC
- https://github.com/thephpleague/flysystem/commit/f3ad69181b8afed2c9edf7be5a2918144ff4ea32 x_refsource_MISC
- https://packagist.org/packages/league/flysystem x_refsource_MISC
- FEDORA-2021-717516a2e9 vendor-advisory, x_refsource_FEDORA
- FEDORA-2021-b9187c535c vendor-advisory, x_refsource_FEDORA