Vulnerability · Published Nov 19, 2020 · Assigned by redhat

CVE-2020-25698

High 7.5

In plain English

A high-severity improper access control in moodle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.9% (higher than 80% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.5High
Exploit odds (30 days)1.9%top 20.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them unenrolling users without having permission to do so. Versions affected: 3.5 to 3.5.14, 3.7 to 3.7.8, 3.8 to 3.8.5, 3.9 to 3.9.2 and earlier unsupported versions. Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistmoodle/moodle3.9.3GHSA-vxhx-gmhm-623c
Packagistmoodle/moodle3.8.6GHSA-vxhx-gmhm-623c
Packagistmoodle/moodle3.7.9GHSA-vxhx-gmhm-623c
Packagistmoodle/moodle3.5.15GHSA-vxhx-gmhm-623c

Affected products (as reported)

VendorProductVersions
n/a moodle Fixed in 3.9.3Fixed in 3.8.6Fixed in 3.7.9Fixed in 3.5.15Fixed in 3.10

Weakness: CWE-284

References