HasThemes
Products
| Product | CVEs | Exploited | Latest |
|---|---|---|---|
| ShopLentor | 3 | – | Jun 3, 2024 |
| HT Mega – Absolute Addons For Elementor | 2 | – | Feb 29, 2024 |
| WC Builder | 2 | – | Dec 24, 2025 |
| HT Feed | 2 | – | Jun 8, 2024 |
| HT Easy GA4 ( Google Analytics 4 ) | 2 | – | Mar 19, 2024 |
| HT Mega | 1 | – | May 17, 2024 |
| HT Menu | 1 | – | Jul 11, 2023 |
| JustTables | 1 | – | Jul 11, 2023 |
| Really Simple Google Tag Manager | 1 | – | Apr 6, 2023 |
| Swatchly | 1 | – | Jul 11, 2023 |
| Swatchly – WooCommerce Variation Swatches for Products | 1 | – | Aug 20, 2026 |
| Swatchly – WooCommerce Variation Swatches for Products (product attributes: Image swatch, Color swatches, Label swatches) | 1 | – | Apr 10, 2025 |
| WC Builder – WooCommerce Page Builder for WPBakery | 1 | – | Dec 21, 2025 |
| WP Plugin Manager | 1 | – | Nov 13, 2025 |
| Extensions For CF7 | 1 | – | Mar 19, 2024 |
| WP Templata | 1 | – | Mar 3, 2025 |
| Extensions For CF7 (Contact form 7 Database, Conditional Fields and Redirection) | 1 | – | Feb 17, 2023 |
| Free WooCommerce Theme 99fy Extension | 1 | – | Jan 9, 2025 |
| HashBar – WordPress Notification Bar | 1 | – | Dec 29, 2023 |
| HT Builder – WordPress Theme Builder for Elementor | 1 | – | Nov 4, 2024 |
Exploited and recent CVEs
- CVE-2026-66605 WordPress Swatchly – WooCommerce Variation Swatches for Products plugin <= 1.4.13 - Cross Site Scripting (XSS) vulnerability 0.3%
- CVE-2025-68533 WordPress WC Builder plugin <= 1.2.0 - Cross Site Scripting (XSS) vulnerability 0.2%
- CVE-2025-14054 WC Builder <= 1.2.0 - Authenticated (Shop Manager+) Stored Cross-Site Scripting via 'heading_color' Shortcode Attribute 0.2%
- CVE-2025-64271 WordPress WP Plugin Manager plugin <= 1.4.7 - Cross Site Request Forgery (CSRF) vulnerability 0.1%
- CVE-2025-2719 Swatchly – WooCommerce Variation Swatches for Products (product attributes: Image swatch, Color swatches, Label swatches) 1.2.8 - 1.4.0 - Missing Authorization to Authenticated (Subscriber+) Limited Options Update 0.3%
- CVE-2025-26917 WordPress WP Templata plugin <= 1.0.7 - Reflected Cross Site Scripting (XSS) vulnerability 0.3%
- CVE-2025-22801 WordPress Free WooCommerce Theme 99fy Extension plugin <= 1.2.8 - Cross Site Scripting (XSS) vulnerability 0.2%
- CVE-2024-51682 WordPress HT Builder – WordPress Theme Builder for Elementor plugin <= 1.3.0 - Stored Cross Site Scripting (XSS) vulnerability 0.3%
- CVE-2024-35699 WordPress HT Feed plugin <= 1.2.8 - Cross Site Scripting (XSS) vulnerability 0.3%
- CVE-2024-34767 WordPress ShopLentor plugin <= 2.8.7 - Cross Site Scripting (XSS) vulnerability 0.3%
- CVE-2023-37999 WordPress HT Mega Absolute Addons for Elementor plugin <= 2.2.0 - Unauthenticated Privilege Escalation vulnerability 3.3%
- CVE-2024-29926 WordPress WC Builder plugin <= 1.0.18 - Cross Site Scripting (XSS) vulnerability 0.3%
- CVE-2024-29094 WordPress HT Easy GA4 plugin <= 1.1.7 - Cross Site Scripting (XSS) vulnerability 0.4%
- CVE-2024-29102 WordPress Extensions For CF7 plugin <= 3.0.6 - Unauthenticated Cross Site Scripting (XSS) vulnerability 0.3%
- CVE-2023-51529 WordPress HT Mega Plugin <= 2.3.3 is vulnerable to Cross Site Request Forgery (CSRF) 0.2%
- CVE-2023-50901 WordPress HT Mega Plugin <= 2.3.8 is vulnerable to Cross Site Scripting (XSS) 0.4%
- CVE-2023-51372 WordPress HashBar – WordPress Notification Bar Plugin <= 1.4.1 is vulnerable to Cross Site Scripting (XSS) 0.3%
- CVE-2022-47172 WordPress WooLentor Plugin <= 2.6.2 is vulnerable to Cross Site Request Forgery (CSRF) 0.3%
- CVE-2023-23791 WordPress HT Menu Plugin <= 1.2.1 is vulnerable to Cross Site Request Forgery (CSRF) 0.3%
- CVE-2023-23803 WordPress JustTables – WooCommerce Product Table Plugin <= 1.4.9 is vulnerable to Cross Site Request Forgery (CSRF) 0.3%
- CVE-2023-23792 WordPress Swatchly – WooCommerce Variation Swatches for Products Plugin <= 1.2.0 is vulnerable to Cross Site Request Forgery (CSRF) 0.3%
- CVE-2023-23804 WordPress HT Feed Plugin <= 1.2.7 is vulnerable to Cross Site Request Forgery (CSRF) 0.3%
- CVE-2023-23802 WordPress HT Easy GA4 ( Google Analytics 4 ) Plugin <= 1.0.6 is vulnerable to Cross Site Request Forgery (CSRF) 0.3%
- CVE-2023-23801 WordPress Really Simple Google Tag Manager Plugin <= 1.0.6 is vulnerable to Cross Site Request Forgery (CSRF) 0.3%
- CVE-2022-46798 WordPress WooLentor Plugin <= 2.5.1 is vulnerable to Cross Site Request Forgery (CSRF) 0.2%
- CVE-2023-23899 WordPress Extensions For CF7 Plugin <= 2.0.8 is vulnerable to Cross Site Request Forgery (CSRF) 0.2%