Vulnerability · Published Aug 23, 2026 · Assigned by VulnCheck
CVE-2026-9769justhtml before 1.10.0 Denial of Service via deeply nested HTML
High 7.5
In plain English
A high-severity security flaw in justhtml from EmilStenstrom. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
justhtml through 1.9.1 (fixed in 1.10.0) is vulnerable to uncontrolled recursion leading to denial of service. During JustHTML() construction, TreeBuilder.finish() unconditionally calls _populate_selectedcontent(), which recursively traverses the DOM tree via _find_elements()/_find_element() without a depth bound. An attacker who can supply HTML for parsing can provide deeply nested elements (e.g., ~1000 nested <div> tags, roughly 11 KB) to exceed CPython's default recursion limit and trigger an unhandled RecursionError, which may abort parsing, fail requests, or terminate a worker/process depending on the host application's exception handling.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | justhtml | 1.10.0 | GHSA-v7cf-c9rm-wm3j |
| PyPI | justhtml | 1.10.0 | PYSEC-2026-3854 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| EmilStenstrom | justhtml | 0 – before 1.10.0 |
Weakness: CWE-674 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- GitHub Security Advisory (GHSA-v7cf-c9rm-wm3j) vendor-advisory
- VulnCheck Advisory: justhtml before 1.10.0 Denial of Service via deeply nested HTML third-party-advisory