Vulnerability · Published Oct 2, 2026 · Assigned by apache

CVE-2026-96289Apache Thrift: php `--gen php:inlined` struct readers (and `TProtocol::skipBinary`) have no recursion-depth guard

High 8.2

In plain English

A high-severity security flaw in Apache Thrift from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities).

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.3%top 72.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Uncontrolled Recursion vulnerability in Apache Thrift PHP bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12thriftno fix listedDEBIAN-CVE-2026-96289
Debian:13thriftno fix listedDEBIAN-CVE-2026-96289
Debian:14thriftno fix listedDEBIAN-CVE-2026-96289
Ubuntu:22.04:LTSthriftno fix listedUBUNTU-CVE-2026-96289
Ubuntu:24.04:LTSthriftno fix listedUBUNTU-CVE-2026-96289
Ubuntu:26.04:LTSthriftno fix listedUBUNTU-CVE-2026-96289
Ubuntu:26.10thriftno fix listedUBUNTU-CVE-2026-96289

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Thrift 0 – before 0.25.0

Weakness: CWE-674 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References