Vulnerability · Published Oct 2, 2026 · Assigned by apache

CVE-2026-96277Apache Thrift: Ruby `SimpleServer` ends `serve()` on any non-Transport/Protocol exception

High 8.7

In plain English

A high-severity security flaw in Apache Thrift from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities).

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.3%top 72.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Uncaught exception, Improper Handling of Exceptional Conditions vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12thriftno fix listedDEBIAN-CVE-2026-96277
Debian:13thriftno fix listedDEBIAN-CVE-2026-96277
Debian:14thriftno fix listedDEBIAN-CVE-2026-96277
Ubuntu:22.04:LTSruby-thriftno fix listedUBUNTU-CVE-2026-96277
Ubuntu:24.04:LTSruby-thriftno fix listedUBUNTU-CVE-2026-96277

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Thrift 0 – before 0.25.0

Weakness: CWE-248, CWE-755 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References