Vulnerability · Published Oct 12, 2026 · Assigned by GitHub_M

CVE-2026-95837containerd CRI plugin: Checkpoint restore bypasses destination security context

High 7.8

In plain English

A high-severity privilege mismanagement in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 1% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.8High
Exploit odds (30 days)0.1%top 98.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

containerd is an open-source container runtime. From 2.1.0 until 2.2.7 and 2.3.4, containerd's CRI CreateContainer checkpoint restore is vulnerable because CRIU restores process security state from checkpoint data instead of enforcing the destination ContainerConfig. An attacker who can create a container from a crafted checkpoint can supply restored credentials, capabilities, no_new_privs, and seccomp state. The restored process can run as root with full capabilities and no enforced seccomp filters while CRI status reports the requested configuration. Systems that do not use CRI checkpoint restore are not affected. This issue is fixed in versions 2.2.7 and 2.3.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12containerdno fix listedDEBIAN-CVE-2026-95837
Debian:13containerdno fix listedDEBIAN-CVE-2026-95837
Debian:14containerdno fix listedDEBIAN-CVE-2026-95837
Gogithub.com/containerd/containerdno fix listedGO-2026-6791
Gogithub.com/containerd/containerd/v22.2.7GHSA-p7v4-vr35-mj6f
Gogithub.com/containerd/containerd/v22.3.4GHSA-p7v4-vr35-mj6f
Gogithub.com/containerd/containerd/v22.2.7, 2.3.4GO-2026-6791
Ubuntu:22.04:LTScontainerdno fix listedUBUNTU-CVE-2026-95837
Ubuntu:26.10containerdno fix listedUBUNTU-CVE-2026-95837
Ubuntu:24.04:LTScontainerd-appno fix listedUBUNTU-CVE-2026-95837
Ubuntu:26.04:LTScontainerd-appno fix listedUBUNTU-CVE-2026-95837
Ubuntu:26.10containerd-appno fix listedUBUNTU-CVE-2026-95837
Ubuntu:26.04:LTScontainerd-stableno fix listedUBUNTU-CVE-2026-95837
Ubuntu:26.10containerd-stableno fix listedUBUNTU-CVE-2026-95837

Affected products (as reported)

VendorProductVersions
containerd containerd >= 2.1.0, < 2.2.7>= 2.3.0, < 2.3.4

Weakness: CWE-269 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References