Vulnerability · Published Sep 30, 2026 · Assigned by apache
CVE-2026-95616Apache WSS4J: Unauthenticated denial of service via integer overflow in DER parsing of X.509 certificate extensions
High 7.5
In plain English
A high-severity integer overflow in Apache WSS4J from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities).
Official description
An integer overflow in WSS4J's DER bounds check lets an oversized allocation pass validation. An unauthenticated attacker can send a SOAP message carrying an X.509 certificate whose SubjectKeyIdentifier extension declares a length of 0x7FFFFFFF; WSS4J decodes this while resolving the signature's key reference, before the message is authenticated, so an eleven-byte extension triggers a 2 GB allocation. Repeated requests exhaust server memory. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | wss4j | no fix listed | DEBIAN-CVE-2026-95616 |
| Debian:13 | wss4j | no fix listed | DEBIAN-CVE-2026-95616 |
| Debian:14 | wss4j | no fix listed | DEBIAN-CVE-2026-95616 |
| Ubuntu:22.04:LTS | wss4j | no fix listed | UBUNTU-CVE-2026-95616 |
| Ubuntu:24.04:LTS | wss4j | no fix listed | UBUNTU-CVE-2026-95616 |
| Ubuntu:26.04:LTS | wss4j | no fix listed | UBUNTU-CVE-2026-95616 |
| Ubuntu:26.10 | wss4j | no fix listed | UBUNTU-CVE-2026-95616 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache WSS4J | 4.0.0 – before 4.0.23.0.0 – before 3.0.60 – before 2.4.4 |
Weakness: CWE-190 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H