Vulnerability · Published Oct 2, 2026 · Assigned by apache
CVE-2026-94636Apache Thrift: Python `TZlibTransport` stops enforcing its decompressed-size limit once the limit is exactly used up
High 8.2
In plain English
A high-severity security flaw in Apache Thrift from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities).
Official description
Improper handling of highly compressed data (data amplification), Function call with incorrectly specified arguments, Improper validation of specified quantity in input vulnerability in Apache Thrift py bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | thrift | no fix listed | DEBIAN-CVE-2026-94636 |
| Debian:13 | thrift | no fix listed | DEBIAN-CVE-2026-94636 |
| Debian:14 | thrift | no fix listed | DEBIAN-CVE-2026-94636 |
| Ubuntu:22.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-94636 |
| Ubuntu:24.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-94636 |
| Ubuntu:26.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-94636 |
| Ubuntu:26.10 | thrift | no fix listed | UBUNTU-CVE-2026-94636 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Thrift | 0 – before 0.25.0 |
Weakness: CWE-409, CWE-628, CWE-1284 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://lists.apache.org/thread/33otcgbqd27wf6qq810q56znzbomnhg1 vendor-advisory
- https://lists.apache.org/thread/1rpq0d0g6yzjjzl1z27lwmvhzkn6rbrs vendor-advisory