Vulnerability · Published May 24, 2026 · Assigned by VulDB

CVE-2026-9365Ettercap GG Dissector ec_gg.c FUNC_DECODER heap-based overflow

Medium 5.6

In plain English

A medium-severity heap buffer overflow in Ettercap. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities).

Severity (CVSS 3.1)5.6Medium
Exploit odds (30 days)0.3%top 75.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

A vulnerability has been found in Ettercap up to 0.8.3. The affected element is the function FUNC_DECODER of the file src/dissectors/ec_gg.c of the component GG Dissector. The manipulation of the argument gg leads to heap-based buffer overflow. The attack is possible to be carried out remotely. The complexity of an attack is rather high. The exploitability is described as difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 0.8.4 is sufficient to fix this issue. The identifier of the patch is feeae6fa366e01a3dd9f1857ec6aae847b2ae00c. It is suggested to upgrade the affected component.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ettercapno fix listedDEBIAN-CVE-2026-9365
Debian:13ettercapno fix listedDEBIAN-CVE-2026-9365
Ubuntu:22.04:LTSettercapno fix listedUBUNTU-CVE-2026-9365
Ubuntu:24.04:LTSettercapno fix listedUBUNTU-CVE-2026-9365
Ubuntu:25.10ettercapno fix listedUBUNTU-CVE-2026-9365
Ubuntu:26.04:LTSettercapno fix listedUBUNTU-CVE-2026-9365
Ubuntu:26.10ettercapno fix listedUBUNTU-CVE-2026-9365

Affected products (as reported)

VendorProductVersions
n/a Ettercap 0.8.00.8.10.8.20.8.3

Weakness: CWE-122, CWE-119 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C

References