Vulnerability · Published Sep 18, 2026 · Assigned by VulnCheck
CVE-2026-93587ImageMagick before 7.1.2-31 Policy Bypass via PCD decoder
Low 3.3
In plain English
A low-severity uncontrolled resource consumption in ImageMagick from ImageMagick. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 2% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is supplied, the decoder does not check a configured resource limit, which can result in extra memory allocation. A local user able to pass command line options to ImageMagick can therefore exceed the intended memory policy limit, causing a limited availability impact. The issue is fixed in 7.1.2-31 and 6.9.13-56.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | imagemagick | 8:6.9.11.60+dfsg-1.6+deb12u14 | DEBIAN-CVE-2026-93587 |
| Debian:13 | imagemagick | 8:7.1.1.43+dfsg1-1+deb13u13 | DEBIAN-CVE-2026-93587 |
| Debian:14 | imagemagick | 8:7.1.2.31+dfsg1-1 | DEBIAN-CVE-2026-93587 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| ImageMagick | ImageMagick | 7.0.0 – before 7.1.2-31 |
| ImageMagick | ImageMagick | 0 – before 6.9.13-56 |
Weakness: CWE-400 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
References
- GitHub Security Advisory (GHSA-89wq-f8f6-2j2v) vendor-advisory
- VulnCheck Advisory: ImageMagick before 7.1.2-31 Policy Bypass via PCD decoder third-party-advisory