Vulnerability · Published Sep 18, 2026 · Assigned by VulnCheck
CVE-2026-93586ImageMagick before 7.1.2-31 Use After Free via ImagesToBlob
Low 2.9
In plain English
A low-severity use-after-free in ImageMagick from ImageMagick. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 1% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a use-after-free vulnerability in the ImagesToBlob method, caused by a pointer that is not updated correctly. Exploitation may result in a limited availability impact (e.g., a crash of the affected process). The issue is fixed in versions 7.1.2-31 and 6.9.13-56.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | imagemagick | 8:6.9.11.60+dfsg-1.6+deb12u14 | DEBIAN-CVE-2026-93586 |
| Debian:13 | imagemagick | 8:7.1.1.43+dfsg1-1+deb13u13 | DEBIAN-CVE-2026-93586 |
| Debian:14 | imagemagick | 8:7.1.2.31+dfsg1-1 | DEBIAN-CVE-2026-93586 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| ImageMagick | ImageMagick | 7.0.0 – before 7.1.2-31 |
| ImageMagick | ImageMagick | 0 – before 6.9.13-56 |
Weakness: CWE-416 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
References
- GitHub Security Advisory (GHSA-3rjr-534c-8v67) vendor-advisory
- VulnCheck Advisory: ImageMagick before 7.1.2-31 Use After Free via ImagesToBlob third-party-advisory