Vulnerability · Published May 24, 2026 · Assigned by VulDB
CVE-2026-9358postcss-selector-parser AST Serialization container.js toString recursion
Medium 4.3
In plain English
A medium-severity security flaw in postcss-selector-parser. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A vulnerability was determined in postcss-selector-parser up to 6.1.2/7.1.2. Affected is the function toString of the file src/selectors/container.js of the component AST Serialization. Executing a manipulation can lead to uncontrolled recursion. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 6.1.3 and 7.1.3 is able to address this issue. This patch is called 5bc698cef66f8abd12610dc623e5d67cbc0f869d. It is suggested to upgrade the affected component. The vendor explains, that according to his definition "DoS on server-side on user-generated CSS is low risk for us (since most users compile own CSS with PostCSS)." The commits were backported to 6.x branch, which was the most downloaded version.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-css-loader | no fix listed | DEBIAN-CVE-2026-9358 |
| Debian:13 | node-css-loader | no fix listed | DEBIAN-CVE-2026-9358 |
| Debian:14 | node-css-loader | 6.8.1+~cs14.1.4-1 | DEBIAN-CVE-2026-9358 |
| Ubuntu:22.04:LTS | node-css-loader | no fix listed | UBUNTU-CVE-2026-9358 |
| Ubuntu:24.04:LTS | node-css-loader | no fix listed | UBUNTU-CVE-2026-9358 |
| Ubuntu:25.10 | node-css-loader | no fix listed | UBUNTU-CVE-2026-9358 |
| Ubuntu:26.04:LTS | node-css-loader | no fix listed | UBUNTU-CVE-2026-9358 |
| Ubuntu:26.10 | node-css-loader | no fix listed | UBUNTU-CVE-2026-9358 |
| npm | postcss-selector-parser | 6.1.3 | GHSA-w9m9-85wc-3x92 |
| npm | postcss-selector-parser | 7.1.3 | GHSA-w9m9-85wc-3x92 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| n/a | postcss-selector-parser | 6.1.06.1.16.1.27.1.07.1.17.1.2 |
Weakness: CWE-674, CWE-404 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L/E:P/RL:O/RC:C
References
- VDB-365321 | postcss-selector-parser AST Serialization container.js toString recursion vdb-entry, technical-description
- VDB-365321 | CTI Indicators (IOB, IOC, TTP, IOA) signature, permissions-required
- CVE-2026-9358 | CVE Analysis and Report third-party-advisory
- Submit #813080 | postcss-selector-parser postcss <= 7.1.1 CWE-674: Uncontrolled Recursion third-party-advisory
- https://gist.github.com/bx33661/581e3a38134601c04e19b4dfc9b459b9 exploit
- https://github.com/postcss/postcss-selector-parser/commit/5bc698cef66f8abd12610dc623e5d67cbc0f869d patch
- https://github.com/postcss/postcss-selector-parser/releases/tag/7.1.3 patch