Vulnerability · Published Sep 17, 2026 · Assigned by VulnCheck

CVE-2026-92940vm2 3.11.3 through 3.11.6 HTTPS Credential Exposure via globalAgent

Critical 10.0

In plain English

A critical-severity security flaw in vm2 from patriksimek. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)10.0Critical
Exploit odds (30 days)0.4%top 63.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

vm2 versions 3.11.3 through 3.11.6 expose the host process's real https.globalAgent to sandboxed code when a NodeVM is explicitly configured to allow require('https'). The builtin loader wraps host modules in a read-only proxy, but method calls such as Agent.prototype.on() are forwarded to the underlying host object, so sandbox code can register a listener for the agent's 'free' event. When an unrelated host HTTPS request releases a pooled connection, the listener receives the live host request options and the host TLSSocket, allowing sandboxed code to read the host's Authorization header and private destination host/port, attach a data listener to the released socket and read subsequent host response bodies in plaintext, and issue attacker-chosen authenticated requests using the stolen credentials. The issue is fixed in 3.11.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmvm23.11.7GHSA-h85j-hv3c-qfgq

Affected products (as reported)

VendorProductVersions
patriksimek vm2 3.11.3 – before 3.11.7

Weakness: CWE-668 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L

References