Vulnerability · Published Oct 9, 2026 · Assigned by GitHub_M

CVE-2026-92705Aegisub executes arbitrary code through automatically loaded Automation scripts

High 7.8

In plain English

A high-severity security flaw in Aegisub from TypesettingTools. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 3% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.8High
Exploit odds (30 days)0.1%top 97.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Aegisub is a cross-platform advanced subtitle editor. From 3.2.0 to 3.4.2, Aegisub automatically loads Automation scripts referenced by `Automation Scripts` metadata in `ASS` subtitle projects without asking whether the user trusts the scripts or their authors. An attacker can distribute a crafted `ASS` file together with a referenced malicious Automation script, and opening the `AS`  file executes arbitrary code with the privileges of the Aegisub process. From 3.4.0 to 3.4.2, inconsistent handling of embedded `NUL` characters between extension validation and filesystem operations additionally allows a crafted `ASS/Lua` polyglot to reference and execute itself as a single-file variant. The vulnerability is fixed in Aegisub 3.5.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12aegisubno fix listedDEBIAN-CVE-2026-92705
Debian:13aegisubno fix listedDEBIAN-CVE-2026-92705
Debian:14aegisub3.5.1-1DEBIAN-CVE-2026-92705
Ubuntu:24.04:LTSaegisubno fix listedUBUNTU-CVE-2026-92705
Ubuntu:26.04:LTSaegisubno fix listedUBUNTU-CVE-2026-92705
Ubuntu:26.10aegisubno fix listedUBUNTU-CVE-2026-92705

Affected products (as reported)

VendorProductVersions
TypesettingTools Aegisub >= 3.2.0, < 3.5.0

Weakness: CWE-158, CWE-829 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References