Vulnerability · Published Sep 16, 2026 · Assigned by VulnCheck

CVE-2026-92595Nodemailer before 9.1.1 Security Sandbox Bypass via resolveContent

Medium 5.9

In plain English

A medium-severity security flaw in nodemailer from nodemailer. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.3%top 77.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Nodemailer (npm package `nodemailer`) versions 9.1.0 and earlier do not honor the `disableFileAccess` and `disableUrlAccess` sandbox options when message content is resolved through the public plugin API `MailMessage.resolveContent()` using the documented legacy three-argument signature `resolveContent(data, key, callback)`. Because `shared.resolveContent()` normalizes the missing `options` argument to an empty object, the message-level flags copied into `mail.data` by the MailMessage constructor are discarded, and `resolveContentValue()` skips both access-control checks, reaching `nmfetch(url)` or `fs.createReadStream(path)`. As a result, plugin or application code that resolves untrusted message content (html, text, attachment `path` or `href`) via this API can be induced to read arbitrary local files or issue outbound HTTP(S) requests (server-side request forgery), bypassing the sandbox the application enabled. The internal paths used by `transporter.sendMail()` (`resolveAll()`, `_convertDataImages()`, and the MIME streaming path) are not affected. Fixed in version 9.1.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-nodemailerno fix listedDEBIAN-CVE-2026-92595
Debian:13node-nodemailerno fix listedDEBIAN-CVE-2026-92595
Debian:14node-nodemailer10.0.0+~8.0.1-1DEBIAN-CVE-2026-92595
Ubuntu:22.04:LTSnode-nodemailerno fix listedUBUNTU-CVE-2026-92595
Ubuntu:24.04:LTSnode-nodemailerno fix listedUBUNTU-CVE-2026-92595
Ubuntu:26.04:LTSnode-nodemailerno fix listedUBUNTU-CVE-2026-92595
Ubuntu:26.10node-nodemailerno fix listedUBUNTU-CVE-2026-92595
npmnodemailer9.1.1GHSA-8m3c-c648-2xjj

Affected products (as reported)

VendorProductVersions
nodemailer nodemailer 0 – before 9.1.1

Weakness: CWE-73 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N

References