Vulnerability · Published Oct 7, 2026 · Assigned by apache

CVE-2026-92415Apache Jackrabbit: DavEx client runs Class.forName + (String)-constructor on server-controlled error bodies

Medium 6.9

In plain English

A medium-severity security flaw in Apache Jackrabbit from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities).

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.5%top 53.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

— Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client. A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantiate arbitrary classes from its classpath, which can lead to arbitrary file creation or truncation. Only applications that use jackrabbit-spi2dav (directly or through jackrabbit-jcr2dav) to connect to a remote repository are affected. Jackrabbit servers are not affected. Category: unsafe reflection on wire data (HIGH). This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17. Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12jackrabbitno fix listedDEBIAN-CVE-2026-92415
Debian:13jackrabbitno fix listedDEBIAN-CVE-2026-92415
Debian:14jackrabbitno fix listedDEBIAN-CVE-2026-92415
Ubuntu:22.04:LTSjackrabbitno fix listedUBUNTU-CVE-2026-92415
Ubuntu:24.04:LTSjackrabbitno fix listedUBUNTU-CVE-2026-92415
Ubuntu:26.04:LTSjackrabbitno fix listedUBUNTU-CVE-2026-92415
Ubuntu:26.10jackrabbitno fix listedUBUNTU-CVE-2026-92415

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Jackrabbit 2.23.0 – through 2.23.52.22.0 – through 2.22.42.20.0 – through 2.20.17

Weakness: CWE-470 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/S:N

References