Vulnerability · Published Sep 30, 2026 · Assigned by apache
CVE-2026-89238Apache WSS4J: WSS4J EncryptedHeader child confusion causing wrong protected-header selection
Critical 9.1
In plain English
A critical-severity insufficient verification of data authenticity in Apache WSS4J from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities).
Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.3%top 73.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
WSS4J EncryptedHeader child confusion could promote an attacker-controlled plaintext element as the decrypted header, leading to incorrect confidentiality coverage and possible policy bypass. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | wss4j | no fix listed | DEBIAN-CVE-2026-89238 |
| Debian:13 | wss4j | no fix listed | DEBIAN-CVE-2026-89238 |
| Debian:14 | wss4j | no fix listed | DEBIAN-CVE-2026-89238 |
| Ubuntu:22.04:LTS | wss4j | no fix listed | UBUNTU-CVE-2026-89238 |
| Ubuntu:24.04:LTS | wss4j | no fix listed | UBUNTU-CVE-2026-89238 |
| Ubuntu:26.04:LTS | wss4j | no fix listed | UBUNTU-CVE-2026-89238 |
| Ubuntu:26.10 | wss4j | no fix listed | UBUNTU-CVE-2026-89238 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache WSS4J | 4.0.0 – before 4.0.23.0.0 – before 3.0.60 – before 2.4.4 |
Weakness: CWE-345 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N