Vulnerability · Published Sep 30, 2026 · Assigned by apache
CVE-2026-88920Apache WSS4J: SAML Sender-Vouches Authentication Bypass
Critical 9.8
In plain English
A critical-severity improper authentication in Apache WSS4J from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities).
Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)0.6%top 52.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
An authentication bypass in the DOM security processor in Apache WSS4J allows unauthenticated remote attackers to forge authenticated SOAP messages via a crafted unsigned SAML sender-vouches assertion containing an attacker-controlled key. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | wss4j | no fix listed | DEBIAN-CVE-2026-88920 |
| Debian:13 | wss4j | no fix listed | DEBIAN-CVE-2026-88920 |
| Debian:14 | wss4j | no fix listed | DEBIAN-CVE-2026-88920 |
| Ubuntu:22.04:LTS | wss4j | no fix listed | UBUNTU-CVE-2026-88920 |
| Ubuntu:24.04:LTS | wss4j | no fix listed | UBUNTU-CVE-2026-88920 |
| Ubuntu:26.10 | wss4j | no fix listed | UBUNTU-CVE-2026-88920 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache WSS4J | 4.0.0 – before 4.0.23.0.0 – before 3.0.60 – before 2.4.4 |
Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H