Vulnerability · Published Sep 10, 2026 · Assigned by GitHub_M

CVE-2026-88060Angular: SSR XSS via Unescaped <template> Content Across DocumentFragment Boundaries in Fallback Raw-Content Elements

High 8.6

In plain English

A high-severity cross-site scripting in angular from angular. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)0.4%top 69.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.30, 21.2.22, and 22.1.4, Angular server-side rendering (SSR) in @angular/platform-server serializes untrusted input inside template content nested in fallback raw-content elements such as noscript, iframe, noembed, and noframes. The Domino serializer's fallbackRawContentTags traversal stopped at the DocumentFragment used by template.content, so matching closing tags in xmp, style, script, comments, or text nodes were not escaped. Standard interpolation with comments or text nodes is reachable without relaxed schemas; literal xmp or style requires CUSTOM_ELEMENTS_SCHEMA or NO_ERRORS_SCHEMA, while Renderer2 imperative DOM construction is unconditionally affected. When HTML5 RAWTEXT browser parsing encounters the unescaped closing tag, it exits the fallback container and interprets trailing markup as active DOM elements, enabling arbitrary JavaScript execution. This issue is fixed in versions 20.3.30, 21.2.22, and 22.1.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12angular.jsno fix listedDEBIAN-CVE-2026-88060
Debian:13angular.jsno fix listedDEBIAN-CVE-2026-88060
Ubuntu:22.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-88060
Ubuntu:24.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-88060
Ubuntu:26.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-88060
Ubuntu:26.10angular.jsno fix listedUBUNTU-CVE-2026-88060
npm@angular/platform-serverno fix listedGHSA-v3p8-whq6-r5jg
npm@angular/platform-server20.3.30GHSA-v3p8-whq6-r5jg
npm@angular/platform-server22.1.4GHSA-v3p8-whq6-r5jg
npm@angular/platform-server21.2.22GHSA-v3p8-whq6-r5jg

Affected products (as reported)

VendorProductVersions
angular angular <= 19.2.25>= 20.0.0, < 20.3.30>= 21.0.0, < 21.2.22>= 22.0.0, < 22.1.4

Weakness: CWE-79, CWE-116 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References