Vulnerability · Published Sep 10, 2026 · Assigned by GitHub_M
CVE-2026-88056Angular: SSRF and Cross-Origin Credential Disclosure via URL Resolution Discrepancy in SSR
High 8.6
In plain English
A high-severity server-side request forgery in angular from angular. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.30, 21.2.22, and 22.1.4, Angular Server-Side Rendering in @angular/platform-server processes user-controlled resource or request URLs through HttpClient after application code validates them with WHATWG URL parsing. The resolveUrl and parseUrl utilities called String.prototype.trim(), which removed leading Unicode whitespace such as U+00A0 or U+FEFF after the input passed a same-origin check, converting a relative path into a protocol-relative attacker-controlled URL. In affected applications that attach sensitive server-side credentials such as Authorization headers to approved requests, relativeUrlsTransformerInterceptorFn then dispatched the request to the attacker-controlled origin, causing SSRF and credential disclosure. This issue is fixed in versions 20.3.30, 21.2.22, and 22.1.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | angular.js | no fix listed | DEBIAN-CVE-2026-88056 |
| Debian:13 | angular.js | no fix listed | DEBIAN-CVE-2026-88056 |
| Ubuntu:22.04:LTS | angular.js | no fix listed | UBUNTU-CVE-2026-88056 |
| Ubuntu:24.04:LTS | angular.js | no fix listed | UBUNTU-CVE-2026-88056 |
| Ubuntu:26.04:LTS | angular.js | no fix listed | UBUNTU-CVE-2026-88056 |
| Ubuntu:26.10 | angular.js | no fix listed | UBUNTU-CVE-2026-88056 |
| npm | @angular/platform-server | no fix listed | GHSA-f6mr-pjwc-34m4 |
| npm | @angular/platform-server | 20.3.30 | GHSA-f6mr-pjwc-34m4 |
| npm | @angular/platform-server | 22.1.4 | GHSA-f6mr-pjwc-34m4 |
| npm | @angular/platform-server | 21.2.22 | GHSA-f6mr-pjwc-34m4 |
Affected products (as reported)
Weakness: CWE-918 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/angular/angular/security/advisories/GHSA-f6mr-pjwc-34m4 x_refsource_CONFIRM
- https://github.com/angular/angular/commit/3e924cc8dbbb57f23b262cb8f0d7e2bd0673034c x_refsource_MISC
- https://github.com/angular/angular/commit/5aa6d97deb9ef1de14e23748b7fa74f97d183132 x_refsource_MISC
- https://github.com/angular/angular/commit/71e52d1396b9cef98652929b73e08c4cde645970 x_refsource_MISC
- https://github.com/angular/angular/releases/tag/v20.3.30 x_refsource_MISC
- https://github.com/angular/angular/releases/tag/v21.2.22 x_refsource_MISC
- https://github.com/angular/angular/releases/tag/v22.1.4 x_refsource_MISC