Vulnerability · Published Sep 30, 2026 · Assigned by apache
CVE-2026-87830Apache WSS4J: Streaming WS-SecurityPolicy validation may skip element-protection checks.
Critical 9.1
In plain English
A critical-severity expression language injection in Apache WSS4J from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities).
Official description
In the StAX streaming WS-SecurityPolicy validator, certain relative or unsupported XPath expressions can be converted into paths that never match the actual XML element path. A remote SOAP peer may therefore send a required element without the expected signature or encryption. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | wss4j | no fix listed | DEBIAN-CVE-2026-87830 |
| Debian:14 | wss4j | no fix listed | DEBIAN-CVE-2026-87830 |
| Ubuntu:24.04:LTS | wss4j | no fix listed | UBUNTU-CVE-2026-87830 |
| Ubuntu:26.04:LTS | wss4j | no fix listed | UBUNTU-CVE-2026-87830 |
| Ubuntu:26.10 | wss4j | no fix listed | UBUNTU-CVE-2026-87830 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache WSS4J | 4.0.0 – before 4.0.23.0.0 – before 3.0.60 – before 2.4.4 |
Weakness: CWE-917 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N