Vulnerability · Published Sep 11, 2026 · Assigned by openjs
CVE-2026-87776compression vulnerable to Denial of Service via memory leak on premature response close
High 7.5
In plain English
A high-severity memory leak in compression from compression. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
compression is a Node.js and Express compression middleware. In versions before 1.8.2, when a client aborts the connection while a compressed response is still being sent, the zlib stream created to compress that response is never destroyed, so each aborted compressed response leaks its native zlib memory. A remote unauthenticated attacker can repeatedly open requests and disconnect early, exhausting the available memory and crashing the server. All applications using compression are affected. The issue is fixed in compression 1.8.2, and users should upgrade to 1.8.2 or later.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-compression | no fix listed | DEBIAN-CVE-2026-87776 |
| Debian:13 | node-compression | no fix listed | DEBIAN-CVE-2026-87776 |
| Debian:14 | node-compression | 1.8.2+~1.8.1-1 | DEBIAN-CVE-2026-87776 |
| Ubuntu:22.04:LTS | node-compression | no fix listed | UBUNTU-CVE-2026-87776 |
| Ubuntu:24.04:LTS | node-compression | no fix listed | UBUNTU-CVE-2026-87776 |
| Ubuntu:26.04:LTS | node-compression | no fix listed | UBUNTU-CVE-2026-87776 |
| Ubuntu:26.10 | node-compression | no fix listed | UBUNTU-CVE-2026-87776 |
| npm | compression | 1.8.2 | GHSA-vc2v-76pw-4v95 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| compression | compression | 0 – before 1.8.2 |
Weakness: CWE-401, CWE-459 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H