Vulnerability · Published Oct 15, 2026 · Assigned by openjs

CVE-2026-87029undici vulnerable to Denial of Service via unhandled exception in the decompress interceptor

Medium 5.9

In plain English

A medium-severity security flaw in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.3%top 82.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

undici is an HTTP client library for Node.js. In versions 7.15.0 through 7.30.0 and 8.0.0 through 8.12.1, its decompress interceptor forwards decompressed response data to the downstream handler from zlib stream event callbacks without catching exceptions those callbacks may throw, and while undici's engine converts a synchronous throw from a downstream handler into a per-request failure, that protection is absent when the throw happens asynchronously from a zlib callback. As a result, a downstream handler that throws by design, such as the built-in dump interceptor which throws when a response exceeds its configured maximum size, escapes as an uncaught exception that terminates the Node.js process. A malicious or compromised HTTP server can crash any client that composes the decompress interceptor with such a handler by returning a small compressed body that decompresses to more than the configured limit, so only the decompressed size matters and the bytes on the wire stay tiny. The issue is fixed in undici 7.30.1 and 8.12.2, and users should upgrade to one of those versions or later. As a workaround, avoid composing the decompress interceptor with a response handler that throws during response processing until upgrading.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-undicino fix listedDEBIAN-CVE-2026-87029
Debian:13node-undicino fix listedDEBIAN-CVE-2026-87029
Debian:14node-undici8.12.2+dfsg+~cs3.2.3-1DEBIAN-CVE-2026-87029
Ubuntu:24.04:LTSnode-undicino fix listedUBUNTU-CVE-2026-87029
Ubuntu:26.04:LTSnode-undicino fix listedUBUNTU-CVE-2026-87029
Ubuntu:26.10node-undicino fix listedUBUNTU-CVE-2026-87029
npmundici8.12.2GHSA-55wc-3pg8-jfw6
npmundici7.30.1GHSA-55wc-3pg8-jfw6

Affected products (as reported)

VendorProductVersions
undici undici 7.15.0 – before 7.30.18.0.0 – before 8.12.2

Weakness: CWE-248 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

References