Vulnerability · Published Sep 23, 2026 · Assigned by apache

CVE-2026-87022Apache Tomcat: WebSocket message smuggling with per-message-deflate

High 7.5

In plain English

A high-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 54.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper handling of length parameter inconsistency vulnerability in Apache Tomcat allows WebSocket message smuggling when per-message-deflate is used. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0.M1 through 9.0.121. The following versions were EOS at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.56 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.1.22, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12tomcat10no fix listedDEBIAN-CVE-2026-87022
Debian:13tomcat10no fix listedDEBIAN-CVE-2026-87022
Debian:14tomcat1010.1.60-1DEBIAN-CVE-2026-87022
Debian:13tomcat11no fix listedDEBIAN-CVE-2026-87022
Debian:14tomcat11no fix listedDEBIAN-CVE-2026-87022
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-87022
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-87022
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-87022
Ubuntu:24.04:LTStomcat10no fix listedUBUNTU-CVE-2026-87022
Ubuntu:26.04:LTStomcat10no fix listedUBUNTU-CVE-2026-87022
Ubuntu:26.10tomcat10no fix listedUBUNTU-CVE-2026-87022
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2026-87022
Ubuntu:26.10tomcat11no fix listedUBUNTU-CVE-2026-87022
Ubuntu:24.04:LTStomcat9no fix listedUBUNTU-CVE-2026-87022
Ubuntu:26.04:LTStomcat9no fix listedUBUNTU-CVE-2026-87022
Ubuntu:26.10tomcat9no fix listedUBUNTU-CVE-2026-87022

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.2510.1.0-M1 – through 10.1.599.0.0.M1 – through 9.0.1218.5.0 – through 8.5.1007.0.56 – through 7.0.109

Weakness: CWE-130 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References