Vulnerability · Published Sep 16, 2026 · Assigned by AMZN

CVE-2026-86831Improper validation of pod identifier uniqueness in aws-network-policy-agent in Amazon EKS

High 8.7

In plain English

A high-severity security flaw in amazon-vpc-cni-k8s from AWS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities).

Severity (CVSS 3.1)8.7High
Exploit odds (30 days)0.6%top 49.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper validation of pod identifier uniqueness in aws-network-policy-agent in Amazon EKS Network Policy Agent before v1.4.0 might allow an authenticated remote user to bypass NetworkPolicy enforcement on co-located pods in other namespaces via crafted pod and namespace names that produce pod identifier collisions. To remediate this issue, users should upgrade to Amazon EKS Network Policy Agent 1.4.0 or later and Amazon VPC CNI Managed Add-on v1.22.4 or later (which includes Network Policy Agent v1.4.0).

Affected products (as reported)

VendorProductVersions
AWS aws-network-policy-agent 0 – before 1.4.0
AWS amazon-vpc-cni-k8s 1.14.0 – before 1.22.4

Weakness: CWE-1289 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N

References