Vulnerability · Published Sep 15, 2026 · Assigned by openjs

CVE-2026-86818fast-uri vulnerable to mailto header injection via percent-encoded field-name desynchronization

Medium 4.8

In plain English

A medium-severity security flaw in fast-uri from fast-uri. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.8Medium
Exploit odds (30 days)0.3%top 83.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

fast-uri is a dependency-free RFC 3986 URI parser for Node.js, used by Fastify and ajv, that added a mailto scheme parser in version 4.1.3. In versions 4.1.3 and 4.1.4, the mailto parser compares each query field name to the reserved names to, subject, and body while the name is still percent-encoded, and decodes it only when storing it as a generic header, so a percent-encoded spelling of a reserved field name is not recognized as that field at parse time but is re-emitted as the literal field name when the parsed URI is serialized. An application that validates, logs, or displays the recipient list from the first parse and then serializes the URI and sends it can silently gain an attacker-chosen recipient, and the subject and body fields can be smuggled across the same roundtrip. The issue is fixed in fast-uri 4.1.5, and users should upgrade to 4.1.5 or later. As a workaround, do not act on a mailto URI that fast-uri has re-serialized without first decoding and re-validating its recipient, subject, and body fields.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13node-ajvno fix listedDEBIAN-CVE-2026-86818
Debian:14node-ajv8.20.0~ds+~cs7.1.6-1DEBIAN-CVE-2026-86818
Ubuntu:22.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-86818
Ubuntu:24.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-86818
Ubuntu:26.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-86818
Ubuntu:26.10node-ajvno fix listedUBUNTU-CVE-2026-86818
npmfast-uri4.1.5GHSA-jvvf-x445-j334

Affected products (as reported)

VendorProductVersions
fast-uri fast-uri 4.1.3 – before 4.1.5

Weakness: CWE-172, CWE-436 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

References