Vulnerability · Published Oct 2, 2026 · Assigned by apache
CVE-2026-86537Apache Thrift: A truncated HTTP request stops the D library's server, allowing an unauthenticated remote attacker to deny service
High 8.7
In plain English
A high-severity infinite loop in Apache Thrift from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities).
Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.4%top 70.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Uncaught exception, Loop with unreachable exit condition ('infinite loop'), Integer underflow (wrap or wraparound) vulnerability in Apache Thrift D language bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | thrift | no fix listed | DEBIAN-CVE-2026-86537 |
| Debian:13 | thrift | no fix listed | DEBIAN-CVE-2026-86537 |
| Debian:14 | thrift | no fix listed | DEBIAN-CVE-2026-86537 |
| Ubuntu:22.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-86537 |
| Ubuntu:24.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-86537 |
| Ubuntu:26.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-86537 |
| Ubuntu:26.10 | thrift | no fix listed | UBUNTU-CVE-2026-86537 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Thrift | 0 – before 0.25.0 |
Weakness: CWE-248, CWE-835, CWE-191 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://lists.apache.org/thread/33otcgbqd27wf6qq810q56znzbomnhg1 vendor-advisory
- https://lists.apache.org/thread/k14jfr1xwc0vtmm2s7xro6lt7q4y6s7m vendor-advisory