Vulnerability · Published Sep 15, 2026 · Assigned by openjs

CVE-2026-86472fast-uri vulnerable to inconsistent host case normalization via percent-encoded octets

Medium 4.8

In plain English

A medium-severity security flaw in fast-uri from fast-uri. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.8Medium
Exploit odds (30 days)0.3%top 83.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

fast-uri is a dependency-free RFC 3986 URI parser for Node.js, used by Fastify and ajv. In versions before 2.4.7, from 3.0.0 through 3.1.7, and from 4.0.0 through 4.1.4, fast-uri folds the host to lowercase before it percent-decodes the host, so a percent-encoded uppercase octet such as %41 decodes to a literal A that is never folded. For a scheme-relative reference such as //host there is no scheme, so the host canonicalization that would normally repair this does not run, and parse, normalize, and equal then disagree on the same host. An application that makes a case-sensitive host decision on fast-uri output, for example a host allowlist or denylist that compares the parsed host or uses equal, can be steered past the check with a percent-encoded uppercase octet, and because hostnames are case-insensitive in DNS and HTTP the evading spelling still reaches the host the check meant to gate. The issue is fixed in fast-uri 2.4.7, 3.1.8, and 4.1.5, and users should upgrade to one of those versions or later. As a workaround, compare hosts case-insensitively by lowercasing the parsed host before any allowlist or denylist decision.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13node-ajvno fix listedDEBIAN-CVE-2026-86472
Debian:14node-ajv8.20.0~ds+~cs7.1.6-1DEBIAN-CVE-2026-86472
Ubuntu:22.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-86472
Ubuntu:24.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-86472
Ubuntu:26.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-86472
Ubuntu:26.10node-ajvno fix listedUBUNTU-CVE-2026-86472
npmfast-uri2.4.7GHSA-hrr3-gc8f-f4qj
npmfast-uri3.1.8GHSA-hrr3-gc8f-f4qj
npmfast-uri4.1.5GHSA-hrr3-gc8f-f4qj

Affected products (as reported)

VendorProductVersions
fast-uri fast-uri 0 – before 2.4.73.0.0 – before 3.1.84.0.0 – before 4.1.5

Weakness: CWE-178 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

References