Vulnerability · Published Sep 7, 2026 · Assigned by VulnCheck

CVE-2026-86431commonmark before 2.9.1 XSS via AttributesExtension form feed bypass

High 7.2

In plain English

A high-severity cross-site scripting in commonmark from thephpleague. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.2High
Exploit odds (30 days)0.4%top 66.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

league/commonmark (thephpleague/commonmark) versions >= 2.7.0 and < 2.9.1 contain a cross-site scripting vulnerability in the AttributesExtension. Prefixing an attribute name with a single U+000C form feed byte (e.g. {\x0Conclick="alert(1)"}) bypasses the AttributesHelper::filterAttributes() 'on*' event-handler filter because PHP's trim() does not strip U+000C, causing the attribute to be written verbatim into the output where browsers parse it as a genuine event handler. The same prefix also defeats the allow_unsafe_links check, allowing javascript: URIs through href/src attributes even when allow_unsafe_links is false. Exploitation requires processing untrusted Markdown with the AttributesExtension enabled; the injected script executes when the rendered HTML is viewed. Fixed in 2.9.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12php-league-commonmarkno fix listedDEBIAN-CVE-2026-86431
Debian:13php-league-commonmarkno fix listedDEBIAN-CVE-2026-86431
Debian:14php-league-commonmark2.10.0-1DEBIAN-CVE-2026-86431
Packagistleague/commonmark2.9.1GHSA-f8fg-pg57-v4j8
Ubuntu:26.04:LTSphp-league-commonmarkno fix listedUBUNTU-CVE-2026-86431

Affected products (as reported)

VendorProductVersions
thephpleague commonmark 2.7.0 – before 2.9.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

References