Vulnerability · Published Sep 7, 2026 · Assigned by VulnCheck
CVE-2026-86429commonmark before 2.9.1 Denial of Service via SmartPunct and Attributes
High 7.5
In plain English
A high-severity security flaw in commonmark from thephpleague. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The league/commonmark (thephpleague/commonmark) library in versions >= 1.5.0 and < 2.9.1 contains quadratic parsing complexity in its SmartPunctExtension and AttributesExtension. When either extension is explicitly registered on the Environment (they are not enabled by default and are excluded from the standard CommonMark and GitHub-Flavored Markdown converters), an unauthenticated attacker can submit small, specially crafted Markdown documents — such as text alternating with unpaired quotes, contiguous runs of block-level attribute blocks, or repeated class attributes — to trigger disproportionate CPU consumption and cause a denial of service. Fixed in 2.9.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | php-league-commonmark | no fix listed | DEBIAN-CVE-2026-86429 |
| Debian:13 | php-league-commonmark | no fix listed | DEBIAN-CVE-2026-86429 |
| Debian:14 | php-league-commonmark | 2.10.0-1 | DEBIAN-CVE-2026-86429 |
| Packagist | league/commonmark | 2.9.1 | GHSA-jjv6-8j6v-6j52 |
| Ubuntu:26.04:LTS | php-league-commonmark | no fix listed | UBUNTU-CVE-2026-86429 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| thephpleague | commonmark | 1.5.0 – before 2.9.1 |
Weakness: CWE-407 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- GitHub Security Advisory (GHSA-jjv6-8j6v-6j52) vendor-advisory
- VulnCheck Advisory: commonmark before 2.9.1 Denial of Service via SmartPunct and Attributes third-party-advisory